[Help] rear hyd brake won't release

Discussion in 'Motorbike Technical Discussion' started by Sean, Jun 26, 2006.

  1. Sean

    Sean Guest

    I knew there was a problem when my Ultra Classic didn't seem to coast
    very well; something seemed to be grabbing it. The rear brake pedal
    action seemed wrong, too, as if the master cyl was already engaged.

    So like an idiot I blistered my thumb testing whether the rear brake
    disc was warm... shit that was hot. And the color's a bit blue.

    I've been riding this bike to work but it looks like I'll have to
    take the van until I can figure out how to get the brake to
    free up. Can anyone give me a quick fix so I can at least ride
    the bike to the repair shop?

    TIA, Sean_Q_

    '99 FLHTCUI
     
    Sean, Jun 26, 2006
    #1
    1. Advertisements

  2. Sean

    Sean Guest

    Thanks guys, will try.

    Sean_Q_
     
    Sean, Jun 26, 2006
    #2
    1. Advertisements

  3. Sean

    anybody43 Guest

    Rear brake not releasing
    I think that this could also be caused by the master cylinder's
    piston not returning to its correct rest position. In turn this could
    be
    the result of the lever not being adjusted properly or I guess
    corrosion or other gunge in the cylinder. There should be a
    small amount of "free play" in the lever before the hydraulic
    piston starts to move.
     
    anybody43, Jun 26, 2006
    #3
  4. Sean

    sharkey Guest

    Yep, what he said. (Or crap in the MC, or sticky piston seals, or ...
    but it's worth checking the MC piston returns fully before you do
    anything expensive!)

    -----sharks
     
    sharkey, Jun 27, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.