Indicators not working - what could be wrong? (SR250)

Discussion in 'Australian Motorcycles' started by Mark, Sep 10, 2007.

  1. Mark

    Mark Guest


    I was riding along recently and the indicators stopped working out of
    the blue. I've checked the fuse which seems to be intact, and someone
    told me that if the flasher relay was busted that the indicator light
    would come on, but not flash. I'm assuming that a busted globe
    wouldn't cause the whole set to stop working. I tried to get the
    switch housing off but one of the screws has a dodgy head. I sprayed
    WD40 into the gap just in case some contacts might be gummed up, but
    it's still not working. Does anyone have any idea what else I can
    look into? Not having any indicators is kind of a show-stopper :)

    It's a 1985 SR250.


    -- Mark
    Mark, Sep 10, 2007
    1. Advertisements

  2. In on Mon, 10 Sep 2007 08:52:51 -0000
    The switchgear is the likely culprit.

    Do your best to get the thing off, or go to a good wrecker or bike
    shop with lotsastuff and buy a replacement - that will have the
    standard Yam gear with lights on/off/hi/lo and horn and flashers on it
    and there's an aftermarket one available.

    You might want to replace the flashercan anyway. Get an electronic
    one, they manage didgy electrics way better than the old relay ones

    Zebee Johnstone, Sep 10, 2007
    1. Advertisements

  3. Mark

    Boxer Guest

    Don't you just hate Dodgy Head!

    Boxer, Sep 10, 2007
  4. Mark

    Toosmoky Guest

    I had dandruff so I told the missus I wanted some Head & Shoulders and
    she said "How do you give shoulders?"...
    Toosmoky, Sep 10, 2007
  5. Mark

    Yeebok Guest

    I'd go for any sort of head really.
    Yeebok, Sep 11, 2007
  6. Mark

    Mark Guest

    G'day Bruce and others,

    Thanks for the info (and jokes!). I bought a hacksaw blade and
    changed the screw to a flat-head variety, and got the switch housing
    off. It was pretty gunky inside but I don't know if that was due to
    the amount of WD40 I sprayed in. I cleaned it up and it still doesn't
    work. Though, it was hard to get to every last nook of the switch
    housing so I'll try a bit more today. Got a mate coming around this
    arvo to have a look too.

    Someone at work suggested the possibility that there was a surge which
    might have blown all the globes. Sounds unlikely but I'll check for
    that too.

    Will keep ya posted,

    -- Mark

    Mark, Sep 16, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.