Re: Yamaha Radian -- Won't keep running

Discussion in 'Motorbike Technical Discussion' started by gdotmarsh@gmail.com, Sep 5, 2015.

  1. Guest

    Reviving a 15 year old thread just to tell you people how much I love you (and leave confirmation for anyone else who stumbles across it).

    I've got a '90 Radian that I have spent *forever* trying to diagnose and checked fuel, spark, air, electrical, valve clearance, jets, *everything* trying to figure out.

    I knew that I had a leaky carb, but I couldn't figure out how that would cause the issue. I rebuilt the carb with new float needles and verified float height and still had the issue.

    Upon reading your reply, Mark, I initially called shenanigans and figured it was a keyboard hero making stuff up, but I knew I hadn't changed the oil lately and it did smell of gasoline, so I went outside and after trying everything else, disconnected the crankcase vent and *voila*, problem solved. I can hardly believe it.

    So I'll give it an oil change tomorrow now that the leaking issue is solvedand make sure that was the issue.

    I've spent a lot of time around Jeeps and motorcycles and have *never* heard of such a thing before, but you saved my bacon, so thank you thank you thank you!!!!!

    Best,
    Geoff
     
    , Sep 5, 2015
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.